Home / Jailbreak / UltraSn0w 1.3 doesn’t work in iOS 5.0 / 5.1 yet.

About J8mesz

I don't strive to be #1, but to be the only one.

2 comments

  1. its freaking me out when i can able to jailbreak my iPad 2 with latest iOS

Leave a Reply